phpMyAdminで「MySQLを5.5.0以降にアップデートしてください」というエラーが出る

投稿日 : 2015年2月2日  タグ : |

サーバーに最新の「phpMyAdmin」を導入して起動しようとしたところ、「MySQLを5.5.0以降にアップデートしてください」というエラーが表示されることがある。これは、サーバーにインストールされているMySQLのバージョンが古すぎるために起きるエラーだ。「yum」コマンドでインストールしたPHPやMySQLはバージョンが古くなっていることが多い。phpMyAdminが対応している最新版のMySQLにアップデートしてから起動すればエラーは表示されなくなるぞ。

「MySQLを5.5.0以降にアップデートしてください」に対応する

mysqlv_01
phpMyAdminにログインしようしたところ、「MySQLを5.5.0以降にアップデートしてください」というエラーが出た。サーバーにインストールされているMySQLのバージョンが古くて、最新のphpMyAdminは対応していないようだ


# yum remove mysql*

既にインストールされているMySQLをアンインストールしよう

# yum localinstall https://dev.mysql.com/get/mysql-community-release-el6-5.noarch.rpm

「yum」コマンドを使って、MySQLのアップデート、インストールを行う

# mysql --version

インストールが完了したら、MySQLのバーションを確認してみよう

mysqlv_02
MySQLのバージョンが表示される。「MySQL 14.14」と表示されているのを確認






おすすめ記事